HDU1671Phone List

3474 ワード

タイトルリンク:HDU 1671
Phone List
Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 16342    Accepted Submission(s): 5498
Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 
Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 
Sample Input

   
   
   
   
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346

 
Sample Output

   
   
   
   
NO YES

标题:番号が山積みになっていて、中にある番号が別の番号の接頭辞であるかどうかを尋ねる
テーマ分析:各電話番号は辞書ツリーに挿入され、マークの末尾は同時に判断子が条件に合わない.注意条件に合致しないのは、挿入時に次のノードが列の末尾であることを発見したり、末尾に挿入してサブツリーが存在していることを発見したりする2つです.関数を検索する必要はありません.関数を挿入して削除すればいいです.
//
//  main.cpp
//  HDU1671
//
//  Created by teddywang on 16/3/30.
//  Copyright © 2016  teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m;
typedef struct node {
    bool flag;
    node *next[10];
}trienode;
trienode *root;
char s[12];
bool flag;

void insert_node(char *s)
{
    trienode *t,*r=root;
    int len=strlen(s);
    for(int i=0;i<len;i++)
    {
        int buf=s[i]-'0';
        if(r->next[buf]==NULL)
        {
            t=new node;
            t->flag=false;
            for(int j=0;j<10;j++)
                t->next[j]=NULL;
            r->next[buf]=t;
            r=t;
        }
        else
        {
            r=r->next[buf];
            if(r->flag==true)
                flag=false;
        }
    }
    for(int i=0;i<10;i++)
    {
        if(r->next[i]!=NULL)
        {
            flag=false;
            break;
        }
    }
    r->flag=true;
}

void del(trienode *r)
{
    for(int i=0;i<10;i++)
    {
        if(r->next[i]!=NULL)
            del(r->next[i]);
    }
    free(r);
}

int main()
{

    cin>>n;
    for(int i=0;i<n;i++)
    {
        root=new node;
        for(int i=0;i<10;i++)
            root->next[i]=NULL;
        root->flag=false;
        cin>>m;
        flag=true;
        for(int j=0;j<m;j++)
        {
            scanf("%s",s);
            insert_node(s);
        }
        if(flag==true)
            cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
        del(root);
    }
}