HDOJ 1006 Tick and Tick


Problem Description
The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.
 
Input
The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.
 
Output
For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.
 
Sample Input

   
   
   
   
0 120 90 -1

 
Sample Output

   
   
   
   
100.000 0.000 6.251
//
//  main.cpp
//  1006
//
//  Created by     on 16/2/17.
//  Copyright © 2016     . All rights reserved.
//
            ,        
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
int d;
double trf(double a)
{
    if(a-180.0>0) return 360.0-a;
    else return a;
}
int func(int h1,int m1,int s1)
{
    double h,m,s,d1,d2,d3,r1,r2,r3;
    s=s1;
    m=m1+s1*(1.0/60.0);
    h=h1+m1*(1.0/60.0)+s1*(1.0/3600.0);
    d1=6.0*s;
    d2=6.0*m;
    d3=30.0*h;
    r1=trf(abs(d1-d2));
    r2=trf(abs(d1-d3));
    r3=trf(abs(d2-d3));
    if(r1-d>=0&&r2-d>=0&&r3-d>=0) return 1;
    else return 0;
}
int main(int argc, const char * argv[]) {
    while(scanf("%d",&d)==1&&d!=-1)
    {
        float counter=0;
        double res=0;
        int s,m,h;
        s=m=h=0;
        for(int i=1;i<=43200;i++)
        {
            s++;
            if(s==60)
            {
                m++;
                s=0;
                if(m==60)
                {
                    h++;
                    m=0;
                    if(h==12)
                        h=0;
                }
            }
            //if(i==43200) cout<<h<<" "<<m<<" "<<s<<endl;
            if(func(h,m,s)==1) {counter++;}
        }
        res=100*(counter/43200);
        printf("%.3f",res);
    }
    return 0;
}