浙江省ACMコンテスト(2013)---B-Break Standard Weight(DFS)


B - Break Standard Weight
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit 
Status 
Practice 
ZOJ 3706
Description
The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term "scales"for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.
With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 1, 4, 5 or 6 exactly.
In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.
Input
There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ x, y ≤ 100
Output
For each test case, output the maximum number of possible special masses.
Sample Input
2
4 9
10 10

Sample Output
13
9

大体の意味は2つの称托にその中の1つを2つに分けることができて、それから3つの秤の測定できる最大重量数を求めて、うん.ということだったはず~~


#include <iostream>
#include <cstring>
using namespace std;
bool used[101][101][101];
void dzswap(int &a,int &b,int &c)
{
    if(a>b)swap(a,b);
    if(a>c)swap(a,c);
    if(b>c)swap(b,c);
}
bool use[201];
int time__;
int index2;
void dfs(int a,int b,int c,int sum=0,int count=0)
{
    if(count==index2)
    {
        if(sum>0&&(!use[sum]))
        {
            use[sum]=true;
            time__++;
        }
        return;
    }
    dfs(0,b,c,sum-a,count+1);
    dfs(0,b,c,sum+a,count+1);
    dfs(a,b,0,sum-c,count+1);
    dfs(a,b,0,sum+c,count+1);
    dfs(a,0,c,sum-b,count+1);
    dfs(a,0,c,sum+b,count+1);
}
int getnum(int a,int b,int c)
{
    time__=0;
    memset(use,0,sizeof(use));
    index2=3;
    dfs(a,b,c);
    return time__;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        memset(used,0,sizeof(used));
        int x,y;
        cin>>x>>y;
        int a,b,c;
        int i;
        int t;
        int max=0;
        for(i=1; i<x; i++)
        {
            a=i;
            b=x-i;
            c=y;
            dzswap(a,b,c);
            if(used[a][b][c])continue;
            used[a][b][c]=true;
            t=getnum(a,b,c);
            if(t>max)max=t;
        }
        for(i=1; i<y; i++)
        {
            a=i;
            b=y-i;
            c=x;
            dzswap(a,b,c);
            if(used[a][b][c])continue;
            used[a][b][c]=true;
            t=getnum(a,b,c);
            if(t>max)max=t;
        }
        cout<<max<<endl;
    }
    return 0;
}