PAT 1124 Raffle for Weibo Followers python解法


1124 Raffle for Weibo Followers(20分)John got a full mark on PAT.(抽選)for his followers on Weibo–that is,he would select winners from every N followers who forwarded his post,and give away gifts.Now you are supposed to help him generate the list of winners.
Input Specification: Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.
Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.
Output Specification: For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going… instead.
Sample Input 1: 9 3 2 Imgonnawin! PickMe PickMeMeMeee LookHere Imgonnawin! TryAgainAgain TryAgainAgain Imgonnawin! TryAgainAgain Sample Output 1: PickMe Imgonnawin! TryAgainAgain Sample Input 2: 2 3 5 Imgonnawin! PickMe Sample Output 2: Keep going…
題意:模擬微博抽選では、1行目に3つの数(m,n,s)が与えられ、それぞれ抽選に参加した人数、受賞者数、抽選規則(s個人を隔てて1つ)が示され、元に抽出された場合は次に順延される.
問題解決の考え方:リストcandidateで受賞者のニックネームを保存して、まず抽選に参加する人数nが抽選規則sより小さいかどうかを判断して、もし小さいならば受賞者がなくて、Keep going…を出力して、さもなくば先にs-=1(リストインデックスが0から始まるため)を使って、順番にニックネームがcandidateの中にあるかどうかを判断して、もしあるならば、s+=1、いないならば、抽選規則(i=s)を満たすかどうかを判断して、満たすとcandidateにニックネームが追加され、s+=nになります.
m, n, s = map(int,input().split())
#m, n, s = 9,3,2
#m, n, s = 2,3,5
l = []
for i in range(m):
    l.append(input())
#l = ['Imgonnawin!','PickMe']  
#l = ['Imgonnawin!','PickMe','PickMeMeMeee','LookHere','Imgonnawin!','TryAgainAgain','TryAgainAgain','Imgonnawin!','TryAgainAgain']
candidate = []
if s>n:
    print('Keep going...')
else:
	s -= 1
    for i in range(m):
        if l[i] in candidate:
            s += 1 
        if i == s and l[i] not in candidate:
            candidate.append(l[i])
            s += n       
    print('
'
.join(candidate))