PAT 1136 A Delayed Palindrome python解法


1136 A Delayed Palindrome(20点)Consider a positive integer N written in standard notation with k+1 digits a i as aki⋯a 1 a 0 with 0≦a i<10 for alli and ak>0.Then N is palindromic if and only if a​i​​ = ak-1​​ for all i. Zero is written 0 and is also palindromic by definition.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )
Given any positive integer, you are supposed to find its paired palindromic number.
Input Specification: Each input file contains one test case which gives a positive integer no more than 1000 digits.
Output Specification: For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:
A + B = C where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.
Sample Input 1: 97152 Sample Output 1: 97152 + 25179 = 122331 122331 + 133221 = 255552 255552 is a palindromic number. Sample Input 2: 196 Sample Output 2: 196 + 691 = 887 887 + 788 = 1675 1675 + 5761 = 7436 7436 + 6347 = 13783 13783 + 38731 = 52514 52514 + 41525 = 94039 94039 + 93049 = 187088 187088 + 880781 = 1067869 1067869 + 9687601 = 10755470 10755470 + 07455701 = 18211171 Not found in 10 iterations.
題意:数xを与え、この数にその反転数を加え、加算結果が回文数であるか否かを判断すると、x is a palindromic numberが出力.そうでなければ結果に結果の反転を加える判断を継続し、10回以降も返信数が得られていない場合はNot found in 10 iterationsを出力する.
解題構想:2つの関数を定義し、1つの関数palindromic(n)はnが回文数であるかどうかを判断し、もう1つの関数f_sum(a)は,問題意に従って求和操作を行い,10回ループし,nが回文数であるか否かを判断するたびに,対応する結果を出力してループを飛び出し,そうでなければ求和を継続し,10回ループが完了した後に対応する結果を出力する.
n = input()
def palindromic(n):
    if n[::-1] == n:
        print(n +' is a palindromic number.')
        return True
    else:
        return False
def f_sum(a):
    b = int(a[::-1])
    a = int(a)
    print('%d + %d = %d'%(a,b,a+b))
    return str(a+b)
for i in range(10):
    if palindromic(n):
        break
    n = f_sum(n)
else:
    print('Not found in 10 iterations.')