PAT 1037 Magic Coupon python解法


1037 Magic Coupon(25分)The magic shop in Mars is offering some magic coupons.Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification: Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​ , followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​ , followed by a line with N​P​​ product values. Here 1≤N​​C,N​P​​ ≤10​5​​ , and it is guaranteed that all the numbers will not exceed 2​30​​ .
Output Specification: For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input: 4 1 2 4 -1 4 7 6 -2 -3 Sample Output: 43
标题:ある謎のショップで、いくつかのクーポンを配布して、あなたはこれらのクーポンを使ってn倍の製品価値を得ることができて、クーポン{1 2 4−1}と製品価値{7 6−2−3}にとって、クーポンxの製品価値=得た優遇、もし最大の製品価値を得るならば、最大のクーポンを最大の製品価値に使うことができて、例えば4 x 7=28、最大を順に選択し、最終的に4 x 7+2 x 6+(-1)*(-3)=43となります.クーポンと製品価値の積がマイナスであれば、お店に料金を支払うことに注意してください.
最大の利益を得るには、まずソートするに違いないが、その中に負数と正数があり、後で処理しにくいので、正負数を分離して、それぞれ保存することができると考えている.ループを行う場合は、クーポンの個数と製品の個数が必ずしも等しくないことに注意し、1つの判断を加えれば解決します.また,2つの負数を乗算すると,最小はかえって利益が最大となる.
n = int(input())
coupon = list(map(int,input().split()))
m = int(input())
products = list(map(int,input().split()))
#n = 4
#coupon = [1, 2, 4, -1]
#m = 4
#products = [7, 6,-2,-3]
coupon.sort(reverse = True)
products.sort(reverse = True)
positive_coupon = [i for i in coupon if i > 0]
negative_coupon = [i for i in coupon if i < 0]
positive_products = [i for i in products if i > 0]
negative_products = [i for i in products if i < 0]

get = 0
length = min(len(positive_products),len(positive_coupon))
for i in range(length):
    get +=  positive_products[i] * positive_coupon[i]
    
length = min(len(negative_coupon),len(negative_products))
for i in range(-length,0):
    get += negative_coupon[i] * negative_products[i]
print(get)