PAT A 1093. Count PAT's (25)


タイトル
The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.
Now given any string, you are supposed to tell the number of PAT's contained in the string.
Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.
Output Specification:
For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.
Sample Input:
APPAPT

Sample Output:
2

典型的なdp問題は
s[j]において、「PAT」のi番目の要素位置に一致したときの一致数はnum[i][j]と表され、
1、s[j]がPAT[i]に等しい場合、num[i][j]=num[i][j-1]+num[i-1][j];
2、そうでなければnum[i][j]=num[i][j-1].
余剰はオーバーフロー防止のため、ケース1の度に余剰を取ればよい.
コード:
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
using namespace std;

int main()
{
	string s;
	cin>>s;

	if(s.empty())
	{
		cout<<0;
		return 0;
	}
	char cf[3]={'P','A','T'};
	vector<vector<int>> num(3,vector<int>(s.size(),0));	//num[i][j]   s[j]      cf[0~i]    
	if(s[0]=='P')	//dp
		num[0][0]=1;
	for(int i=1;i<s.size();i++)
		if(s[i]=='P')
			num[0][i]=num[0][i-1]+1;
		else
			num[0][i]=num[0][i-1];
	for(int i=1;i<3;i++)
		for(int j=1;j<s.size();j++)
			if(s[j]==cf[i])
			{
				num[i][j]=num[i][j-1]+num[i-1][j];
				num[i][j]%=1000000007;
			}
			else
				num[i][j]=num[i][j-1];

	cout<<num[2][s.size()-1];

	return 0;
}