素数表


Description
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively. 
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.
 
Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 
100 and 2 <= L <= 10 
6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
 
Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.
 
Sample Input

     
     
     
     
143 10 143 20 667 20 667 30 2573 30 2573 40 0 0

 
Sample Output

     
     
     
     
GOOD BAD 11 GOOD BAD 23 GOOD BAD 31

 
#include<iostream>
#include<cstdio>
#include<string>
#include<cmath>

using namespace std;

int kw[1001];
bool zhengchu(int n,int lkw)					//     ?
{
	int sum=0;
	for(int i=lkw-1;i>=0;i--)
		sum=(sum*1000+kw[i])%n;

   if(sum%n==0)
	   return true;
   return false;
}

bool sushu[1000001]={0};//0   

void ss()
{
	sushu[0]=1;
	sushu[1]=1;
	for(int i=2;i*i<1000005;i++)
	{
		if(sushu[i]==0)
		{
			for(int j=2*i;j<1000005;j+=i)
				sushu[j]=1;
		}
	}
}
int main()
{
	string s;
	int n;
	cin>>s;
	ss();
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;

	  memset(kw,0,sizeof(kw));
	  int sum=0;
	  int i=0;
	 for(i=0;i<s.length();i++)
	 {
	     int ii=(s.length()+2-i)/3-1;
		  kw[ii]=s[i]-'0'+10*kw[ii];
	 }
		for(i=2;i<n;i++)
		{
			if(!sushu[i]&&zhengchu(i,(s.length()+2)/3))
			{
				cout<<"BAD"<<' '<<i<<endl;
				break;
			}
		}
		if(i==n)
			cout<<"GOOD"<<endl;

		cin>>s;
	}


}

この問題から学べる
素数を判断する簡便な方法
bool sushu[1000001] = { 0 };//0は素数
void ss()
{
sushu[0] = 1;
sushu[1] = 1;
for (int i = 2; i*i<1000005; i++)
{
if (sushu[i] == 0)
{
for (int j = 2 * i; j<1000005; j += i)
sushu[j] = 1;
}
}
}
 
大きなデータの進数変換もあり、大きな数を千進数データに変換し、処理を速めます.
Int kw[10000];
s入力文字列を進数変換し、
 memset(kw,0,sizeof(kw));
  int i=0;
 for(i=0;i {
     int ii=(s.length()+2-i)/3-1;
  kw[ii]=s[i]-'0'+10*kw[ii];
 }
注意高位はkwの後ろにあり、まず処理し、残りのデータ*1000+の上位に処理します.
int kw[1001];
bool zhengchu(int n,int lkw)
{
//削除できますか?
int sum=0;
for(int i=lkw-1;i>=0;i--)
sum=(sum*1000+kw[i])%n;
   if(sum%n==0)
   return true;
   return false;
}