トポロジーソート---ループがあるかどうかを判断

6717 ワード

Legal or Not
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3823    Accepted Submission(s): 1738
Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows"like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?
We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.
Please note that the "master and prentice"relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 
 
Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 
 
Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 
 
Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0
 
Sample Output
YES
NO
【出典】
HDOJ Monthly Contest – 2010.03.06
【テーマ大意】
ACM-DIYというQQ群には多くの神牛がいて、私のようなスラグもあります.スラグたちはよく質問しています.長い間、師弟関係が形成されていましたが、一部の師弟関係は合法ではありません.例えば、AはBの師匠で、BはAの師匠で、つまり環を形成したのは合法ではありません.今、いくつかの師弟関係をあげて、合法かどうかを判断させます.
 
【テーマ分析】
実はあなたに1つの図をあげて、あなたに回路を形成するかどうかを判断させて、もしできるならば合法ではありませんて、さもなくば合法です.
単純なトポロジソート
 
#include<iostream>
#include<cstring>
#define MAX 110
using namespace std;
int n,m,a,b,i,j,k,x;
bool Map[MAX][MAX];
int indegree[MAX];

void topsort()
{
    for(k=1,i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
        {
            if(!indegree[j])
            {
                k++;
                indegree[j]--;
                for(x=1;x<=n;x++)
                    if(Map[j][x])
                        indegree[x]--;
                break;
            }
            if(j>n)
                return;
        }
    }
}
int main()
{
    while(cin>>n>>m,n)
    {
        memset(Map,0,sizeof(Map));
        memset(indegree,0,sizeof(indegree));
        for(i=1;i<=m;i++)
        {
            cin>>a>>b;
            a++;
            b++;
            if(!Map[a][b])
            {
                Map[a][b]=1;
                indegree[b]++;
            }
        }
        topsort();
        if(k-1==n)
            cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}