HDU 1405 The Last Practice(暴力列挙)
The Last Practice
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9522 Accepted Submission(s): 2034
Problem Description
Tomorrow is contest day, Are you all ready? We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final. Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem. what does this problem describe? Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.
Input
Input file contains multiple test case, each case consists of a positive integer n(1Output
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.
Sample Input
Sample Output
Author
lcy
Source
杭電ACM合宿チーム訓練試合(IV)
标题:暴力列挙2~sqrt(n)、記録回数、出力、注意入出力フォーマット.....(このピット)
ACコード:
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9522 Accepted Submission(s): 2034
Problem Description
Tomorrow is contest day, Are you all ready? We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final. Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem. what does this problem describe? Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.
Input
Input file contains multiple test case, each case consists of a positive integer n(1
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.
Sample Input
60 12 -1
Sample Output
Case 1. 2 2 3 1 5 1 Case 2. 2 2 3 1
Hint
60=2^2*3^1*5^1
Author
lcy
Source
杭電ACM合宿チーム訓練試合(IV)
标题:暴力列挙2~sqrt(n)、記録回数、出力、注意入出力フォーマット.....(このピット)
ACコード:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
int main()
{
int n;
int m=1;
while(cin>>n)
{
int j;
if(n<0)break;
if(m>1)cout<<endl;
cout<<"Case "<<m++<<"."<<endl;
if(n==1)cout<<"1 1 ";
for(int i=2;i<=sqrt(n);i++)
{
j=0;
while(n%i==0)
{
n=n/i;
j++;
}
if(j)
cout<<i<<" "<<j<<" ";
}
if(n!=1)
cout<<n<<" "<<"1"<<" ";
cout<<endl;
}
return 0;
}