HDU 1002 A+B ProblemII(大数加算)

3313 ワード

A + B Problem II
                                                                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)                                                                                          Total Submission(s): 271671    Accepted Submission(s): 52508
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input

   
   
   
   
2 1 2 112233445566778899 998877665544332211

 
Sample Output

   
   
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 
       大数の問題は,配列シミュレーションで計算する問題である.加算は、計算数の加算を配列でシミュレートし、各ビットを加算します.
コードを添付:
 
#include<iostream>
#include<algorithm>
#include<cstring>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    char a[1050],b[1050];
    int c[1050],d[1050],sum[1050];
    int n,num = 0;
    cin >> n;
    getchar();
    while(n--)
    {
        num++;
        memset(c,0,sizeof(c));
        memset(d,0,sizeof(d));
        memset(sum,0,sizeof(sum));
        cin >> a >> b;
        int j = 0;
        for(int i = strlen(a) - 1;i >= 0;i--)    //      
        {
            c[j++] = a[i] - '0';
        }
        j = 0;
        for(int i = strlen(b) - 1;i >= 0;i--)     //      
        {
            d[j++] = b[i] - '0';
        }
        int len = strlen(a) > strlen(b) ? strlen(a) : strlen(b);  //              
        int jin = 0;
        for(int i = 0;i < len;i++)
        {
            sum[i] = c[i] + d[i] + jin ;
            jin = 0;
            if(sum[i] > 9 && i < len - 1)         //  i  =  len - 1           ,          
            {
                jin = sum[i]/10;
                sum[i] = sum[i]%10;
            }
        }
        if(num != 1)          //          
		cout << endl;
        cout << "Case " << num << ":" << endl;
        cout << a << " + " << b << " = ";
        for(int i = len-1;i >= 0;i--)
        {
            cout << sum[i];       
        }
        cout << endl;
     }
     return 0;
}