杭電ACM-1004 Let the Balloon Rise

3664 ワード

Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 61287    Accepted Submission(s): 22571
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you. 
 
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 
Sample Input
 
   
5 green red blue red red 3 pink orange pink 0
 

Sample Output
 
   
red pink
 


题意:

找出出现次数最多的颜色

解题思路:

利用HashMap的特性,key值存放颜色,value值存放数量。最终遍历HashMap根据数量找出目标颜色

解题代码:
import java.util.HashMap;
import java.util.Map;
import java.util.Scanner;

public class Main1004 {
	
	public static String getMostPopularColor(Map colorMap) {
		String color = null;
		int count = 0;
		for (Map.Entry entry : colorMap.entrySet()) {
			if (entry.getValue() > count) {
				count = entry.getValue();
				color = entry.getKey();
			}
		}
		return color;
	}
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int total = 0;
		while ((total = sc.nextInt()) != 0) {
			sc.nextLine();
			Map colorMap = new HashMap();
			while (total > 0) {
				String color = sc.nextLine();
				Integer count = colorMap.get(color);
				if (count == null) {
					colorMap.put(color, 1);
					total--;
					continue;
				}
				colorMap.put(color, count+1);
				total--;
			}
			System.out.println(getMostPopularColor(colorMap));
		}
	}
}