1005 hdoj Number Sequence(java関数フォーマット)

2135 ワード

Number Sequence
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 145944    Accepted Submission(s): 35462
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input

   
   
   
   
1 1 3 1 2 10 0 0 0

 
Sample Output

   
   
   
   
2 5

 
Author
CHEN, Shunbao
 
Source
ZJCPC2004
 
Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1004  1021  1019  1003
テーマの意味はとてもはっきりしていて、あなたに式をあげてあなたにあげた数をあげて、関数の再帰を運用して、私はjava関数を復習して、たたいて、ある程度向上することを望んでいます.関数文法の知識を忘れないようにjava関数に新鮮なコードを差し上げます
<pre name="code" class="java">import java.util.*;
import java.math.*;
import java.io.*;
public class Main {
public static int fun(int x,int y,int z)
{
	if(z==1||z==2)
	{
		return 1;
	}
	else
	{
	 z = (x * fun(x, y, z - 1) + y * fun(x, y, z - 2)) %7;//  
	return z;
	}
	
}
	public static void main(String[] args) {
		// TODO Auto-generated method stub
    Scanner in = new Scanner(System.in);
    while(in.hasNext())
    {
    	int a,b,c;
    	a=in.nextInt();
    	b=in.nextInt();
    	c=in.nextInt();
    	if(a==0&&b==0&&c==0)
    	break;
    	else
    	{
    		System.out.println(fun(a,b,c%49));//    %49 %7    ·, %49    
    	}
    }
    

	}

}