HDU1316:How Many Fibs?(大数JAVA)

2449 ワード

L - How Many Fibs?
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit 
Status
Description
Recall the definition of the Fibonacci numbers: 
f1 := 1 
f2 := 2 
fn := fn-1 + fn-2 (n >= 3) 
Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 
 
Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros. 
 
Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 
 
Sample Input

        
        
        
        
10 100 1234567890 9876543210 0 0

 
Sample Output

        
        
        
        
5 4

 
題意:aより大きいbより小さいフィボナッチの数
分析:大数、JAVAを使いましょう
コード:
import java.io.*;
import java.math.*;
import java.util.*;
import java.text.*;
 
public class Main {
 
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        BigInteger[] dp = new BigInteger[1000];
        dp[1] = BigInteger.ONE;
        dp[2] = BigInteger.ONE.add( BigInteger.ONE );
        dp[3] = dp[1].add(dp[2]);
        int i;
        for (i = 3; i <= 500; ++i) {
            dp[i] = dp[i - 1].add(dp[i - 2]);
        }
        BigInteger l, r;
        while (in.hasNextBigInteger()) {
            int cnt = 0;
            l = in.nextBigInteger();
            r = in.nextBigInteger();
            if (BigInteger.ZERO.equals(l) && BigInteger.ZERO.equals(r)) {
                break;
            }
            for (int j = 1; j <= 500; ++j) {
                if(dp[j].compareTo(r)>0){
                        break;
                }
                if(dp[j].compareTo(l)>=0){
                        cnt++;
                }
            }
            System.out.println(cnt);
        }
        System.exit(0);
    }
}