How Many Trees? カトラン数
2374 ワード
How Many Trees?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4154 Accepted Submission(s): 2350
Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices).
Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree?
Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
Output
You have to print a line in the output for each entry with the answer to the previous question.
Sample Input
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4154 Accepted Submission(s): 2350
Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices).
Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree?
Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
Output
You have to print a line in the output for each entry with the answer to the previous question.
Sample Input
1 2 3
Sample Output
1 2 5
Source
UVA
Recommend
Eddy | We have carefully selected several similar problems for you: 1131 1134 1133 2067 1267
Statistic | Submit | Discuss | Note
import java.util.Scanner;
import java.math.*;
public class Main {
public static void main(String args[]){
int n;
Scanner scan=new Scanner(System.in);
BigInteger f[]=new BigInteger[101];
f[0]=BigInteger.ONE;
f[1]=BigInteger.ONE;
for(int i=2;i<=100;i++)
{
f[i]=f[i-1].multiply(BigInteger.valueOf(4*i-2)).divide(BigInteger.valueOf(i+1));
}
while(scan.hasNext())
{
n=scan.nextInt();
System.out.println(f[n]);
}
}
}