HDU 2817--A sequence of numbers【高速べき乗型取り】

2080 ワード

A sequence of numbers
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3983    Accepted Submission(s): 1219
Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 
Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.
You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 
Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 
Sample Input

   
   
   
   
2 1 2 3 5 1 2 4 5

 
Sample Output

   
   
   
   
5 16

 
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

#define mod 200907

typedef long long LL;

LL pow(LL a,LL b){
    LL ans=1;
    while(b){
        if(b & 1)
            ans=(ans*a)%mod;
        a=(a*a)%mod;
        b>>=1;
    }
    return ans;
}

int main (){
    int n;
    scanf("%d",&n);
    while(n--){
        LL a,b,c,k;
        cin>>a>>b>>c>>k;
        if(b-a+b==c) cout<<((k-1)*(c-b)+a)%mod<<endl;
        else
            cout<<(pow(b/a,k-1)*a)%mod<<endl;
    }
    return 0;
}