HDU 1095 A+B for Input-Output Practice(VII)(入門水題、C、Javaの2バージョン)

1502 ワード

A+B for Input-Output Practice (VII)
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60206    Accepted Submission(s): 40137
Problem Description
Your task is to Calculate a + b.
 
Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
 
Output
For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.
 
Sample Input

   
   
   
   
1 5 10 20

 
Sample Output

   
   
   
   
6 30

 
Author
lcy
原題リンク:http://acm.hdu.edu.cn/showproblem.php?pid=1095
C言語ACコード:
#include <stdio.h>
int main()
{
    int a,b;
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        printf("%d

",a+b); } return 0; }

Java ACコード:
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			int a = sc.nextInt();
			int b = sc.nextInt();
			System.out.println(a+b);
			System.out.println();
		}
	}

}