hdu 2014青年歌手グランプリ_審査委員会の採点の解題報告

5585 ワード

リンク:http://acm.hdu.edu.cn/showproblem.php?pid=2014
若手歌手グランプリでは、審査員が出場選手に点数をつける.選手の得点ルールは、1つの最高点と1つの最低点を除いて、平均得点を計算することです.ある選手の得点をプログラミングして出力してください.
 
Input
入力データには複数のグループがあり、各グループが1行を占め、各行の最初の数はn(2 
Output
各組の入力データに対して、選手の得点を出力し、結果は2桁の小数を保持し、各組の出力は1行を占める.
 
Sample Input

  
    
3 99 98 97 4 100 99 98 97
 
Sample Output

  
    
98.00 98.50
: ;

  
    
/********* hdu 2014 ************/
/********* & ************/
/********* 2011/5/8 ************/
#include < stdio.h >
int t;
float a[ 105 ];
int main(){
while ( scanf( " %d " , & t ) != EOF ){
float min = 100 ,max = 0 ,h = 0 ;
for ( int i = 0 ;i < t; ++ i ){
scanf(
" %f " , & a[i] );
h
+= a[i];
max
= max > a[i] ? max:a[i];
min
= min < a[i] ? min:a[i];
}
h
-= max;
h
-= min;
h
/= (t - 2 );
printf(
" %.2f
" ,h );
}
}