Mayor's posters(線分樹区間更新+離散化)


リンク:http://poj.org/problem?id=2528
Mayor's posters
Time Limit: 1000 MS
 
メモリLimit: 65536 K
Total Submissions: 46164
 
Acceepted: 13379
Description
The citizens of Bytetown,AB,could not stand that the candidates in the mayoral election campaign have been place their electors posters at.The city council hars the finallection thellatwarder 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall;the width of a poster can be any integer number of bytes(byte is the unit of length in Bytetown) 
  • The wall is divided into segments and the width of each segment is byte. 
  • Each poster must copletely cover a contigous number of wall segments.
  • They have built a wall 1000000 bytes long(such that there is enough place for all candidates).When the electotal campaign was reted,the candidates their posters on the wall and their posterwired.wired.the candidates started place their posters on wall segments already occupied by other posters.Everyone in Bytetown was curious wsters will be visible on on the last day beforelecties. 
    Your task is to find the number of visible posters when all the posters are place d given the information abors posters'size,their place and of plocest on the electotalwall. 
    Input
    The first line of input contains a number c giving the number of cases that follow.The first line of data for a single case contains number 1<=n=10000.The subsequent n line describe the poster therever line the Poster line e therever.The therever.The the first the inininders inners line e e e e e e e e e e e e e e e e e e e inderst inderst inderst line e e e e e e e e e e e e e inderst line e
    i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster,repectively.We know that for each 1<=n,1==l
    i <= リ<=100000 0000.After the i-th poster is placced,it entirely covers all wall segments numberd l
    i,l
    i+1,…,ri.
    Output
    For each input data set print the number of visible poster after all the posters are placced. 
    The picture below illustrates the case of the sample input. 
    Mayor's posters(线段树区间更新+离散化)_第1张图片
    Sample Input
    1
    5
    1 4
    2 6
    8 10
    3 4
    7 10
    
    Sample Output
    4
    
    Source
    Albert Colleggiat Prograamming Contect 2003.10.18
    使用する線分樹の機能は、「udate」と「成段置換」があります.簡単hashです.
    AC コード:
    /*
          MLE,           ,   
               ,           ,
               。 
    */ 
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    #include<cmath>
    #include<cstdio>
    #include<queue>
    #define LL long long
    #define MAXN 40005
    using namespace std;
    int linecover[MAXN];
    LL ans;
    struct node{
    	int l,r,c;
    }tree[MAXN*3];
    struct linenode{
    	int id;
    	int s;
    	int f;
    }p[MAXN*3];
    struct lisan{
    	int id;
    	int st;
    	int ed;
    }pp[MAXN*3];
    
    bool cmp(linenode x,linenode y)
    {
    	return x.s<y.s;
    }
    void build(int rt,int s,int e)
    {
    	tree[rt].l=s;
    	tree[rt].r=e;
    	tree[rt].c=0;
    	if(s==e)
    	{
    		return;
    	}
    	int mid=(s+e)/2;
    	build(rt*2,s,mid);
    	build(rt*2+1,mid+1,e);
    }
    void update(int rt,int l,int r,int cnt)
    {
    	if(tree[rt].l==l&&tree[rt].r==r)
    	{
    		tree[rt].c=cnt;
    		return;
    	}
    	int mid=(tree[rt].l+tree[rt].r)/2;
    	if(tree[rt].c!=0)//pushdown   
    	{
    		tree[rt*2].c=tree[rt*2+1].c=tree[rt].c;
    		tree[rt].c=0;
    	}
    	if(r<=mid)
    	{
    		update(rt*2,l,r,cnt);
    	}
    	else if(l>mid)
    	{
    		update(rt*2+1,l,r,cnt);
    	}
    	else
    	{
    		update(rt*2,l,mid,cnt);
    		update(rt*2+1,mid+1,r,cnt);
    	}
    }
    void query(int rt,int l,int r)
    {
    	if(tree[rt].c!=0)
    	{
    		if(!linecover[tree[rt].c])
    		{
    			ans++;
    			linecover[tree[rt].c]=1;
    		}
    		return;
    	}
    	int mid=(l+r)/2;
    	query(rt*2,l,mid);
    	query(rt*2+1,mid+1,r);
    }
    int main()
    {
    	int t,n,i,st,ed;
    	scanf("%d",&t);
    	while(t--)
    	{
    		scanf("%d",&n);
    		for(i=1;i<=n;i++)
    		{
    			scanf("%d%d",&st,&ed);
    			p[i*2-1].s=st;
    			p[i*2-1].f=0;
    			p[i*2-1].id=i;
    			p[i*2].s=ed;
    			p[i*2].id=i;
    			p[i*2].f=1;
    		}
    		sort(p+1,p+2*n+1,cmp);
    		int tmp=p[1].s;
    		int cnt=1;
    /*    ,                poj  RE,         AC*/		
    	  //pp[p[1].id].id=p[1].id;
    	 //pp[p[1].id].st=cnt;//                   
    		for(i=1;i<=2*n;i++)//    
    		{
    			if(tmp!=p[i].s)
    			{
    				cnt++;
    				tmp=p[i].s;
    			}
    			pp[p[i].id].id=p[i].id;
    			if(p[i].f==0)
    			{
    				pp[p[i].id].st=cnt;
    			}
    			else if(p[i].f==1)
    			{
    				pp[p[i].id].ed=cnt;
    			}
    		}
    		memset(linecover,0,sizeof(linecover));
    		build(1,1,cnt);
    		for(i=1;i<=n;i++)
    		{
    			update(1,pp[i].st,pp[i].ed,pp[i].id);
    		}
    		ans=0;
    		query(1,1,cnt);
    		cout<<ans<<endl;
    	}
    	return 0;
    }