人は人に会ってA^B nefu 444を愛します

1524 ワード

人は人を見てA^Bを愛する


Problem : 444


Time Limit : 1000ms


Memory Limit : 65536K


description

 A^B 。
 :A^B “A B ”

input

 , , A B (1<=A,B<=10000), A=0, B=0, , 。

output

 , A^B , 。

sample_input

2 3
12 6
6789 10000
0 0

sample_output

8
984
1

hint


 

source

hdu

 
#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;

int main()
{
    int a,b,k;
    while(cin>>a>>b)
    {
        if(a==0&&b==0)
        break;
        k=1;
        for(int i=1;i<=b;i++)
        {
            k=(k*a)%1000;
        }
        cout<<k<<endl;
    }
    return 0;
}

とても简単で、难易度がありません...