HDOJ 2035人は人に会ってA^Bを爱します

1588 ワード

Problem Description A^Bの最後の3桁で表される整数を求めます.説明:A^Bの意味は「AのB次方」
Input入力データは複数のテストインスタンスを含み、各インスタンスは1行を占め、2つの正の整数AとBからなる(1<=A、B<=10000)、A=0、B=0であれば入力データの終了を示し、処理しない.
Outputテストインスタンスごとに、A^Bの最後の3桁で表される整数を出力し、各出力が1行を占めます.
Sample Input 2 3 12 6 6789 10000 0 0
Sample Output 8 984 1
残りを取ればいいです.後ろの3人を残してください.
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int a = sc.nextInt();
            int b = sc.nextInt();

            if(a==0&&b==0){
                return ;
            }
            int number=1;
            for(int i=0;i<b;i++){
                number = (number*a)%1000;
            }
            System.out.println(number);
        }

    }

}