クラスとオブジェクト2(円の周長と面積)


C++:クラスとオブジェクト2(円の周長と面積)


タイトルの説明:


Description
クラスライターを使用して、後の円の半径を入力し、円の周長と面積を計算して表示します.円周率:3.14
Input
n組の試験例を含み、1行目が試験群数であることを入力します.
2行目–n+1行目テストデータで、各測定データには実数が1つあり、円の半径を表します.
Output
円の周長と面積(小数2桁保持).
Sample Input
3 4.5 14.6 5.5
Sample Output
28.26 63.59 91.69 669.32 34.54 94.98

コード領域

#include<iostream>
using namespace std;
class yuan
{
private:
    float r,s,c;
public:
    void set()
    {     cin>>r;
    }
}
    void zhouchang(){printf("%.2f",3.14*r*2);cout<<' ';
    }
};
int main()
{
    int i,x;
    cin>>x;
    for(i=1;i<=x;i++){
    yuan yi;
    yi.set();
    yi.zhouchang();
    yi.area();}
    return 0;
}