HDOJ 2029 Palindromes _easy version

1841 ワード

Problem Descriptionの「回文列」は、正読みと反読みが同じ文字列で、例えば「level」や「noon」などが回文列です.読み込んだ文字列が「返信」であるかどうかを判断するプログラムを書いてください.
Input入力には複数のテストインスタンスが含まれており、入力データの最初の行は正の整数nであり、テストインスタンスの個数を表し、後にn文字列が続く.
Outputは、文字列が回文列である場合は「yes」を出力、そうでない場合は「no」を出力する.
Sample Input 4 level abcde noon haha
Sample Output yes no yes no
水が通る
import java.util.Scanner;

public class Main {
    public static void main(String args[]){
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        sc.next();
        while(n-->0){
            boolean isNo = false;
            String strs = sc.nextLine();

            for(int i=0;i<strs.length()/2;i++){
                if(strs.charAt(i) != strs.charAt(strs.length()-i-1)){
                    System.out.println("no");
                    isNo = true;
                    break;
                }
            }
            if(!isNo)
            System.out.println("yes");
        }


    }
}