2035:人は人を見てA^Bを愛する


A^Bの最後の3桁の表す整数を求めます.説明:A^Bの意味は「AのB乗」Input入力データは複数のテストインスタンスを含み、各インスタンスは1行を占め、2つの正の整数AとBからなる(1<=A、B<=10000).A=0、B=0の場合、入力データの終了を表し、処理しない.Outputテストインスタンスごとに、A^Bの最後の3桁で表される整数を出力し、各出力が1行を占めます.Sample Input 2 3 12 6 6789 10000 0 0 Sample Output 8 984 1
//2035:  A^B
#include <iostream>
using namespace std;

int main()
{
	int A,B,temp = 1;
	while(cin >> A >> B)
	{
		if(1 > A || A > 10000 || 1 > B || B > 10000)
			return -1;
		for (int i = 0;i < B;i++)
		{
			temp *= A;
			if(temp > 1000)
				temp %= 1000;
		}
		cout << temp <<endl;
		temp = 1;   // : temp 1
	}	

	return 0;
}