Lowest Common Multiple Plus(数論)
1564 ワード
E - Lowest Common Multiple Plus
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit
Status
Practice
HDU 2028
Description
n個数の最小公倍数を求める.
Input
入力には複数のテストインスタンスが含まれ、各テストインスタンスの開始は正の整数nであり、次いでnの正の整数である.
Output
各テスト・データのセットに対して最小公倍数を出力し、各テスト・インスタンスの出力は1行を占めます.最後の出力は32ビットの整数だと仮定できます.
Sample Input
Sample Output
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit
Status
Practice
HDU 2028
Description
n個数の最小公倍数を求める.
Input
入力には複数のテストインスタンスが含まれ、各テストインスタンスの開始は正の整数nであり、次いでnの正の整数である.
Output
各テスト・データのセットに対して最小公倍数を出力し、各テスト・インスタンスの出力は1行を占めます.最後の出力は32ビットの整数だと仮定できます.
Sample Input
2 4 6
3 2 5 7
Sample Output
12
70
#include <iostream>
#include <cstdio>
using namespace std;
long long gcd(long long a, long long b)
{
return b == 0? a : gcd(b, a % b);
}
int main()
{
long long t, i, lcm;
while( cin >> t )
{
int a[t];
for( i=0; i<t; i++ )
cin >> a[i];
if( 1 == t )
cout << a[0] << endl;
else
{
for( i=0; i<t; i++ )
{
if( i<2 )
{
lcm = a[i]*a[i+1]/gcd(a[i],a[i+1]);
i++;
}
else
{
lcm = lcm*a[i]/gcd(a[i],lcm);
}
}
cout << lcm << endl;
}
}
return 0;
}
long long 。。。