HDOJ 2006奇数の積を求めます

1419 ワード

Problem Descriptionはあなたにn個の整数をあげて、彼らの中のすべての奇数の積を求めます.
Input入力データは複数のテストインスタンスを含み、各テストインスタンスは1行を占め、各行の最初の数はnであり、本グループのデータが全部でn個であることを示し、次いでn個の整数であり、各グループのデータには少なくとも1つの奇数があると仮定することができる.
Outputは各セット数の奇数のすべての積を出力し、テストインスタンスに対して1行を出力します.
Sample Input 3 1 2 3 4 2 3 4 5
Sample Output 3 15
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()){
            int n=sc.nextInt();
            int sum=1;
            for(int i=0;i<n;i++){
                int x=sc.nextInt();
                if(x%2!=0)
                    sum*=x;
            }
            System.out.println(sum);
        }
    }

}