PAT (Advanced Level) Practise 1099 Build A Binary Search Tree (30)

2878 ワード

1099. Build A Binary Search Tree (30)


時間の制限
100 ms
メモリ制限
65536 kB
コード長制限
16000 B
クイズルーチン
Standard
作成者
CHEN, Yue
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees. Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2. Input Specification: Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line. Output Specification: For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line. Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output: 58 25 82 11 38 67 45 73 42
並べ替えツリーの中順にシーケンスを小から大まで挿入し、bfs出力します.
#include<cstdio>
#include<vector>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
int ch[maxn][2], n, v[maxn], a[maxn], t;

void dfs(int x)
{
	if (x == -1) return;
	dfs(ch[x][0]);
	v[x] = a[t++];
	dfs(ch[x][1]);
}

int main()
{
	scanf("%d", &n);
	for (int i = 0; i < n; i++) scanf("%d%d", &ch[i][0], &ch[i][1]);
	for (int i = 0; i < n; i++) scanf("%d", &a[i]);
	sort(a, a + n);
	dfs(0);
	queue<int> p;
	p.push(0);
	while (!p.empty())
	{
		int q = p.front(); p.pop();
		printf("%s%d", q ? " " : "", v[q]);
		if (ch[q][0] >= 0) p.push(ch[q][0]);
		if (ch[q][1] >= 0) p.push(ch[q][1]);
	}
	return 0;
}