ZOJ 3323 Somali Pirates


テーマリンク:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3323
タイトル:
ソマリPirates
Time Limit: 1セット     
メモリLimit: 32768 KB
It is said that the famous Somali Pirates hate digits.So their QQ passwords never contain any digit.Ginn some lines of candidate passwords,You are asked to delete all the digits in the passwors
Input
The re are multiple test cases.The first line of input is an integer T (T <= 10)indicating the number of test cases.
Each case contains a line indicating a candidate password.The length of the password is between 1 and 20,inclusive.Besides,the password consists of only digits and English letters.
Output
For each candidate password,delete all the digits and print the remaning characters in a line.
Sample Input
2
BeatLA123
1plus1equals1
Sample Output
BeatLA
plusequals
件名:
    与えられた文字列を削除して出力します。
問題を解く:
    数字がスキップされます。そうでないと出力されます。
コード:
#include <iostream>
#include <string>
using namespace std;
int main()
{
	int t;
	cin>>t;
	string s;
	while(t--)
	{
		cin>>s;
		for(int i=0;i<s.length();i++)
		if(s[i]>='0'&&s[i]<='9')continue;
		else cout<<s[i];
		cout<<endl;
	}
	return 0;
}