POJ 1952一番長い増減(マイナス)サブ数列問題(やや難しい)

3686 ワード

http://poj.org/problem?id=1952
Description
The advice to「buy low」is half the formula to success in the bovine stock maket.To be consided a great investor you must also follows this problems'advice: 
                    "Buy low; buy lower"
Each time you buy a stock,you must purce it a lower price than the previous time you bougt it.The more times You buy at lower price than before,the better!Your goal is to see how many times you can continue purch sing at lower prices. 
You will be given the daily selling prces of a stock(positive 16-bit integers)over a period of time.You can chose to buy stock on the day.Each time you chose to buy,the price must be strictly lower than the previous time you bougt stock.Write a program which dentifies which days You shound buy stock in order to maximize the number of times you. 
Here is a list of stock price: 
 Day   1  2  3  4  5  6  7  8  9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87
The best investor(by this proble、anyway)can buy at most four times if each purch hase is lower then the previous purshes.One four day sequence(there might be others)of acceptable buys: 
Day    2  5  6 10

Price 69 68 64 62
Input
*Line 1:N(1<=N==5000)、the number of days for which stock prces are given 
*Lines 2.etc:A series of N space-separated integers,teper line except the final line whight have fewers. 
Output
Two integers on a single line: 
*The length of the longest sequence of decreasung price 
*The number of sequences that have this length(garanted to fit in 31 bits) 
In counting the number of solutions、two potential solutions are consided the same(and would only count as one solution)if the same streing of decreasing press、that is、if they「look the prewrece」two different sequence of“buy”days could produce the same streing of decreasung press and be counted as only a single solution. 
Sample Input
12
68 69 54 64 68 64 70 67 78 62
98 87
Sample Output
4 2
というテーマに落とし穴があります。同じ長さの二つの列を一つの列としてみます。これは書く時に取捨選択に注意してください。
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int a[10005],dp[10005],count[10005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
            cin >>a[i];
        for(int i=0; i<n; i++)
        {
            dp[i]=1;
            count[i]=1;
        }
        for(int i=0; i<=n; i++)
        {
            for(int j=0; j<i; j++)
            {
                if(a[i]<a[j]&&dp[j]+1>dp[i])
                {
                    dp[i]=dp[j]+1;
                    count[i]=count[j];
                }
                else if(a[i]<a[j]&&dp[j]+1==dp[i])
                    count[i]+=count[j];
            }
            for(int j=i-1; j>=0; j--)//              
                if(a[i]==a[j]&&dp[i]==dp[j])
                {
                    count[j]=0;
                    break;
                }
        }
         /*for(int k=0;k<n;k++)
                printf("%d ",dp[k]);*/
        int len=dp[0],num=count[0];
        for(int i=1; i<n; i++)
        {
            if(len<dp[i])
            {
                len=dp[i];
                num=count[i];
            }
            else if(len==dp[i])
                num+=count[i];
        }
        cout<< len <<" "<< num<<endl;
    }
    return 0;
}