pku 2253は初期から終点までの最長の経路(一部)を記録し、ディジェストラは最短ルートを求める

3771 ワード

Frogger
Time Limit: 1000MS
 
Memory Limit: 65536K
Total Submissions: 31932
 
Accepted: 10288
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 
You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x"and a line saying "Frog Distance = y"where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source
Ulm Local 1997
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
//#define inf 0xffffff
#define inf 527527.0
#include<math.h>
#include<cmath>
#include<iostream>
using namespace std;

float  mp[222][1222];
float dis[222];
int visit[222];
typedef struct
{
    int x;
    int y;
} node;

void suan(int &n)
{

    for(int  i=1; i<=n ; i++)
    {
        dis[i]=mp[1][i];
    }

    visit[1]=1;
    int pos;
    for(int i=1; i<=n-1; i++)
    {

        float   mincost=inf;
        for(int  j=1; j<=n; j++)
        {
            if(!visit[j]&&dis[j]<mincost)
            {
                pos=j;
                mincost=dis[j];

            }
        }
        visit[pos]=1;
        for(int j=1; j<=n; j++)
        {
            if(!visit[j]&&mp[pos][j]!=inf)
                dis[j]=min(dis[j],max(dis[pos],mp[pos][j]));
        }
    }

}
int main()
{

    int n;
    int sb=1;
    node q[220];
    while(scanf("%d",&n))
    {
        if(n==0)
            break;
        memset(mp,inf,sizeof(mp));
        memset(visit,0,sizeof(visit));
        int a,b,c;
        for(int  i=1; i<=n; i++)
        {
            scanf("%d%d",&q[i].x,&q[i].y);
        }
        for(int i=1; i<=n; i++)
            for(int j=1+i; j<=n; j++)
            {
                mp[i][j]=mp[j][i]=sqrt((float)((q[i].x-q[j].x)*(q[i].x-q[j].x)+(q[i].y-q[j].y)*(q[i].y-q[j].y)));
            }
        suan(n);

        printf("Scenario #%d
Frog Distance = %.3lf

",sb++,dis[2]); } }