毎日1つのアルゴリズム_5_Financial Management
2388 ワード
今日の問題はもっと簡単ではありません.選択的な問題を選ぶべきかどうかを考えています.
タイトルはFinancial Managementで、以下の通りです.
Description
Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input
Sample Output
コードは次のとおりです.
作者:jason 0539
微博:http://weibo.com/2553717707
ブログ:http://blog.csdn.net/jason0539(転載は出典をご説明ください)
タイトルはFinancial Managementで、以下の通りです.
Description
Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
Sample Output
$1581.42
コードは次のとおりです.
import java.math.BigDecimal;
import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;
public class FinancialManagement {
public static void main(String args[]){
Scanner in = new Scanner(System.in);
List<Float> list = new ArrayList<Float>();
int all = 12;
while(all > 0){
float f = Float.valueOf(in.nextLine());
list.add(f);
all --;
}
float sum = 0;
for(int i = 0; i < list.size(); i ++){
sum += list.get(i);
}
float average = sum/12;
BigDecimal b = new BigDecimal(average);
average = b.setScale(2, BigDecimal.ROUND_HALF_UP).floatValue();
System.out.println("$"+average);
}
}
作者:jason 0539
微博:http://weibo.com/2553717707
ブログ:http://blog.csdn.net/jason0539(転載は出典をご説明ください)