HDU 1163 Eddy's digital Roots

2340 ワード

計算方法は、この数字のルートが元の数を9で割った余数に等しいため、この計算過程を「合九法」と呼ぶことが多い.例えば39/9=3.成立する
同余定理:2つの積をmで割った余数が、この2つの数がそれぞれmで割った余数積に等しい場合.例えば、7%3=15%3=27*5/3=2=1*2
Eddy's digital Roots
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2759    Accepted Submission(s): 1592
Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.
 
Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).
 
Output
Output n^n's digital root on a separate line of the output.
 
Sample Input

   
   
   
   
2 4 0

 
Sample Output

   
   
   
   
4 4

 
Author
eddy
 
Recommend
JGShining
 
#include <iostream>
#include <stdlib.h>
using namespace std;
int n;
int main( )
{
    while( cin >> n  && n ){
           int sum = 1;
           for( int i=0 ; i<n ; i++ ){
                sum = sum * n % 9;     
           }
           if( sum == 0 )
               cout << 9 << endl;
           else
               cout << sum << endl;
    }
    return 0;
}