1037. Magic Coupon (25)

3055 ワード

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

vector<int> nc_p;
vector<int> nc_n;
vector<int> np_p;
vector<int> np_n;

bool cmp1(int a, int b) {
    return a > b;
}

bool cmp2(int a, int b) {
    return a < b;
}
int main() {
    int nc, np, i, tmp;
    while(cin>>nc) {
        for(i=0; i<nc; i++) {
            cin>>tmp;
            if(tmp >= 0) {
                nc_p.push_back(tmp);
            } else {
                nc_n.push_back(tmp);
            }
        }
        cin>>np;
        for(i=0; i<np; i++) {
            cin>>tmp;
            if(tmp >= 0) {
                np_p.push_back(tmp);
            } else {
                np_n.push_back(tmp);
            }
        }

        sort(nc_p.begin(), nc_p.end(), cmp1);
        sort(nc_n.begin(), nc_n.end(), cmp2);
        sort(np_p.begin(), np_p.end(), cmp1);
        sort(np_n.begin(), np_n.end(), cmp2);
        
        int sum = 0;
        
        for(i=0; i<nc_p.size() && i<np_p.size(); i++) {
            sum += nc_p[i] * np_p[i];
        }
        for(i=0; i<nc_n.size() && i<np_n.size(); i++) {
            sum += nc_n[i] * np_n[i];
        }
        cout<<sum<<endl;
        nc_p.clear();
        nc_n.clear();
        np_p.clear();
        np_n.clear();
    }
    return 0;
}