HDU--2024
1711 ワード
C言語正当識別子
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 45522 Accepted Submission(s): 18355
Problem Description
Cの正当な識別子かどうかを判断する文字列を入力します.
Input
入力データには複数のテストインスタンスが含まれ、データの最初の行は整数nであり、テストインスタンスの数を表し、次いでn行入力データであり、各行は50を超えない文字列である.
Output
入力データのセットごとに1行出力します.入力データがCの正当な識別子である場合、「yes」が出力され、そうでない場合、「no」が出力される.
Sample Input
Sample Output
Author
lcy
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 45522 Accepted Submission(s): 18355
Problem Description
Cの正当な識別子かどうかを判断する文字列を入力します.
Input
入力データには複数のテストインスタンスが含まれ、データの最初の行は整数nであり、テストインスタンスの数を表し、次いでn行入力データであり、各行は50を超えない文字列である.
Output
入力データのセットごとに1行出力します.入力データがCの正当な識別子である場合、「yes」が出力され、そうでない場合、「no」が出力される.
Sample Input
3
12ajf
fi8x_a
ff ai_2
Sample Output
no
yes
no
Author
lcy
#include <iostream>
#include <stdio.h>
#include <cstring>
using namespace std;
int main()
{
char a[60];
int n;
while (cin >>n)
{
getchar();
while (n--)
{
int flag = 0;
gets(a);
int p = strlen(a);
if ( !(a[0] == '_' || (a[0] >='a' && a[0] <='z') ||( a[0] >='A' && a[0] <='Z')))
cout << "no" <<endl;
else
{
for (int i=1; i<p; i++)
{
if ( !(a[i] == '_' || (a[i] >='a' && a[i] <='z') ||( a[i] >='A' && a[i] <='Z') || ( a[i] >= '0'&& a[i] <='9')))
flag++;
}
if (flag==0)
cout << "yes" << endl;
else
cout << "no" << endl;
}
}
}
return 0;
}