HDU-1037-Keep on Truckin'(HDUで一番水の問題は一つもないので、英語の練習のために来てください)


Keep on Truckin'
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10324    Accepted Submission(s): 7147
Problem Description
Boudreaux and Thibodeaux are on the road again . . .
"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"
"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"
"We're not going to make it, I say!"
So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?
 
Input
Input to this problem will consist of a single data set. The data set will be formatted according to the following description.
The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.
 
Output
There will be exactly one line of output. This line will be:
   NO CRASH
if the height of the 18-wheeler is less than the height of each of the underpasses, or:
   CRASH X
otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler). 
The height of the 18-wheeler is 168 inches.
 
Sample Input

   
   
   
   
180 160 170

 
Sample Output

   
   
   
   
CRASH 160

 
Source
South Central USA 2003
 
Recommend
We have carefully selected several similar problems for you:   1040  1032  1064  1038  1056 
HDU、一番水、英語で見る頭は大きいです.
3つの数を入力し、3つの数が168より大きい場合、NO CRASHを出力します.そうでなければ、出力の最初の出現が168以下の数になります!
もしあなたがこの英語からこの意味を見ることができたら、おめでとうございます.あなたは勝った.どうせ私は見ていません!!
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int a,b,c;
    while(scanf("%d%d%d",&a,&b,&c)!=EOF)
    {
        if(a>168&&b>168&&c>168)
        {
            cout<<"NO CRASH"<<endl;
        }
        else if(a<168)
        {
            cout<<"CRASH "<<a<<endl;
        }
        else if(b<168)
        {
            cout<<"CRASH "<<b<<endl;
        }
        else if(c<168)
        {
            cout<<"CRASH "<<c<<endl;
        }
    }
    return 0;
}