2015 ACM ICPC長春試合区ネットワーク試合HDU 5437 Alisha’s Party
Alisha’s Party
Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 980 Accepted Submission(s): 266
Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first. Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter. If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is. The first line of the input gives the number of test cases, T , where 1≤T≤15. In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100. The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi. Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle. The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle. Note: there will be at most two test cases containing n>10000.
Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
Sample Input
Sample Output
Source
2015 ACM/ICPC Asia Regional Changchun Online
标题:k人がいて、一人一人が贈り物を持って、贈り物の貴重さと時間の前後に従ってドアに入って、ドアは特定の時間に開けて特定の人数に入れて、最後にすべての人はドアに入って、ドアに入る順序を尋ねます.
行列問題のシミュレーションである以上,行列は走れないし,贈り物の貴重な先着順を加えると,優先行列を考慮し,贈り物の貴重さや時間に応じて重荷重が小さくなり,行列に1人ずつ増え,大開門時間になると行列から人が出る.
Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 980 Accepted Submission(s): 266
Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first. Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter. If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is. The first line of the input gives the number of test cases, T , where 1≤T≤15. In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100. The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi. Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle. The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle. Note: there will be at most two test cases containing n>10000.
Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
Sample Input
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
Sample Output
Sorey Lailah Rose
Source
2015 ACM/ICPC Asia Regional Changchun Online
标题:k人がいて、一人一人が贈り物を持って、贈り物の貴重さと時間の前後に従ってドアに入って、ドアは特定の時間に開けて特定の人数に入れて、最後にすべての人はドアに入って、ドアに入る順序を尋ねます.
行列問題のシミュレーションである以上,行列は走れないし,贈り物の貴重な先着順を加えると,優先行列を考慮し,贈り物の貴重さや時間に応じて重荷重が小さくなり,行列に1人ずつ増え,大開門時間になると行列から人が出る.
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
#define MAX 150010
using namespace std;
struct Friend
{
char name[210];
int value,time;
friend bool operator<(Friend a,Friend b)//
{
if(a.value==b.value)
return a.time>b.time;
return a.value<b.value;
}
};
struct Open//
{
int t,p;
};
Friend friends[MAX];//
Open open[MAX];//
int ask[110];//
int get_in[MAX];//
bool cmp(const Open& a,const Open& b)//
{
if(a.t<b.t)
return true;
else
return false;
}
int main()
{
int t;
int k,m,q;
int i,j;
int open_count,get_in_count;
scanf("%d",&t);
while(t--)
{
get_in_count=open_count=0;//
scanf("%d%d%d",&k,&m,&q);
for(i=0;i<k;i++)//
{
scanf("%s%d",friends[i].name,&friends[i].value);
friends[i].time=i;
}
open[0].t=-1;// ! m 0 ,
for(i=0;i<m;i++)//
{
scanf("%d%d",&open[i].t,&open[i].p);
}
sort(open,open+m,cmp);// !
for(i=0;i<q;i++)
{
scanf("%d",&ask[i]);
ask[i]--;
}
priority_queue<Friend> que;// ,
for(i=0;i<k;i++)
{
que.push(friends[i]);//
if((i+1)==open[open_count].t)//
{
for(j=0;j<open[open_count].p&&(!que.empty());j++)// p
{
Friend frd=que.top();
que.pop();
get_in[get_in_count++]=frd.time;//
}
open_count++;
}
}
while(!que.empty())//
{
Friend frd=que.top();
que.pop();
get_in[get_in_count++]=frd.time;
}
for(i=0;i<q;i++)//
{
printf("%s%c",friends[get_in[ask[i]]].name,i==q-1?'
':' ');
}
}
return 0;
}