HDU--2032
1666 ワード
楊輝三角
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 43360 Accepted Submission(s): 18223
Problem Description
中学時代に習った楊輝三角を覚えていますか.具体的な定義はここでは説明しません.以下の図を参照してください.
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
Input
入力データには複数のテストインスタンスが含まれ、各テストインスタンスの入力には正の整数n(1<=n<=30)のみが含まれ、出力する楊輝三角の層数を表す.
Output
各入力に対応して、対応する層数の楊輝三角を出力し、各層の整数間をスペースで区切り、各楊輝三角の後ろに空行を追加します.
Sample Input
Sample Output
Author
lcy
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 43360 Accepted Submission(s): 18223
Problem Description
中学時代に習った楊輝三角を覚えていますか.具体的な定義はここでは説明しません.以下の図を参照してください.
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
Input
入力データには複数のテストインスタンスが含まれ、各テストインスタンスの入力には正の整数n(1<=n<=30)のみが含まれ、出力する楊輝三角の層数を表す.
Output
各入力に対応して、対応する層数の楊輝三角を出力し、各層の整数間をスペースで区切り、各楊輝三角の後ろに空行を追加します.
Sample Input
2 3
Sample Output
1
1 1
1
1 1
1 2 1
Author
lcy
#include <iostream>
using namespace std;
int main()
{
int a[40][40];
int c[40][40];
int n;
for (int i=0; i<40; i++)
{
for (int j=0; j<40; j++)
{
if (i==j)
c[i][j]=1;
c[i][0]=1;
}
}
while (cin >> n)
{
if (n==1)
cout << 1<<endl;
else if (n==2)
{
cout << 1<< endl;
cout << 1<< " " << 1 << endl;
}
else
{
for (int i=2; i<n; i++)
{
for (int j=1; j<i; j++)
c[i][j]= c[i-1][j]+c[i-1][j-1];
}
for (int i=0; i<n; i++)
{
for (int j=0; j<i; j++)
{
cout << c[i][j] << " ";
}
cout << c[i][i];
cout <<endl;
}
}
cout << endl;
}
return 0;
}