as easy problem

1614 ワード

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 16297    Accepted Submission(s): 10937
Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 
Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 
Output
for each case, you should the result of y+f(x) on a line.
 
Sample Input

   
   
   
   
6 R 1 P 2 G 3 r 1 p 2 g 3

 
Sample Output

   
   
   
   
19 18 10 -17 -14 -4

 
#include main()
{
char c;
int a,b,d,s,n,w,i,q;
scanf("%d",&q);
getchar();
//while(n--)
for(i=0;i{
scanf("%c%d",&c,&s);
if(c>='A'&&c<='Z')
{a=c-'0'-16;
w=a+s;
//printf("%d",w);
}
//continue;
if(c>='a'&&c<='z')
    {b=c-'0';
    b=b-48;
    a=-b;
   w=a+s;
   //printf("%d",w);
//continue;
}
printf("%d",w);
getchar();
}
  
return 0;
}