HDu 1088 Write a simple HTML Browser文字列処理
Write a simple HTML Browser
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8838 Accepted Submission(s): 2480
Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags)
which is a linebreak and
which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123"is one word, but "abc, 123"are two words, namely "abc,"and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either
or
.
Output
You should display the the resulting text using this rules:
. If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
. If you read a
in the input, start a new line.
. If you read a
in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again).
The last line is ended by a newline character.
Sample Input
Sample Output
行ごとに80を超えないことに注意してください.つまり、最大1行79文字です..の私はここで3回PEをしました...
コード:
君と励まし合う
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8838 Accepted Submission(s): 2480
Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags)
which is a linebreak and
which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123"is one word, but "abc, 123"are two words, namely "abc,"and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either
or
.
Output
You should display the the resulting text using this rules:
. If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
. If you read a
in the input, start a new line.
. If you read a
in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again).
The last line is ended by a newline character.
Sample Input
Hallo, dies ist eine
ziemlich lange Zeile, die in Html
aber nicht umgebrochen wird.
<br>
Zwei <br> <br> produzieren zwei Newlines.
Es gibt auch noch das tag <hr> was einen Trenner darstellt.
Zwei <hr> <hr> produzieren zwei Horizontal Rulers.
Achtung mehrere Leerzeichen irritieren
Html genauso wenig wie
mehrere Leerzeilen.
Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen
wird.
Zwei
produzieren zwei Newlines. Es gibt auch noch das tag
--------------------------------------------------------------------------------
was einen Trenner darstellt. Zwei
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html
genauso wenig wie mehrere Leerzeilen.
行ごとに80を超えないことに注意してください.つまり、最大1行79文字です..の私はここで3回PEをしました...
コード:
#include <stdio.h>
#include <string.h>
char line[10000] , temp[100] ;
char hr[] = "--------------------------------------------------------------------------------" ;
int main()
{
int index = 0 , flag = 0;
while(~scanf("%s",temp))
{
if(strcmp(temp,"<br>") == 0)
{
flag = 0 ;
line[index++] = '
' ;
}
else if(strcmp(temp,"<hr>") == 0)
{
if(flag != 0)
line[index++] = '
' ;
strncpy(line+index,hr,strlen(hr)) ;
index += strlen(hr) ;
line[index++] = '
' ;
flag = 0 ;
}
else
{
if(flag + strlen(temp) + 1 > 80)
{
flag = 0 ;
line[index++] = '
' ;
}
if(flag != 0)
{
line[index++] = ' ' ;
flag ++ ;
}
strncpy(line+index,temp,strlen(temp)) ;
index += strlen(temp) ;
flag += strlen(temp) ;
}
}
line[index] = '\0' ;
puts(line) ;
return 0 ;
}
君と励まし合う