hdu 1394 Minimum Inversion Numberセグメントツリー逆シーケンス数を求める


Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12868    Accepted Submission(s): 7860
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
 
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 
Output
For each case, output the minimum inversion number on a single line.
 
Sample Input

   
   
   
   
10 1 3 6 9 0 8 5 7 4 2

 
Sample Output

   
   
   
   
16

 
Author
CHEN, Gaoli
 
Source
ZOJ Monthly, January 2003
 
Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1698  1540  1542  1255  2795 
 
この問題の鍵はどのように各シーケンスの逆シーケンス数を求めるかであり,問題に記述されているシーケンス生成方法を観察すると,毎回最初の要素を末尾に移動し,数字は0からn−1まで繰り返しない,すなわち,このシーケンスは必ず0からn−1までのn個数からなることがわかる.
最初の数をシーケンスの最後に移動する過程を考慮すると、逆シーケンスペアの定義は前の要素が後の要素より大きいため、a 1が頭にあるとき、それより小さい要素はそれと逆シーケンスペアを構成することができ、全部でa 1ペアがあるに違いない.最後に移動すると、それより大きい要素だけが逆シーケンスペアを構成することができ、n−1−a 1ペアが共有される.
すなわち、a 1を末尾に移動するたびに、a 1対の逆シーケンス対が減少し、n−1−a 1対の逆シーケンス対が増加し、合計n−1−2*a 1が増加する.これは繰返し関係であるため、n−1サイクルで実現できる.
ここでは、初期シーケンスの逆シーケンス数をどのように求めるかという問題があります.方法は大きく3つあります.セグメントツリー、ツリー配列、集計ソートです.前の2つは位置に関連しています.つまり、各要素を位置として処理します.ここでは、セグメントツリーで処理する方法を簡単に紹介します.
1.まずツリーを作成し、各ノードはこの区間内の数字の個数を保存します.
2.毎回1つの数字aを入力して、aからn-1までの区間の数字の個数を探して、もしこの区間内に数字があるならば、aより大きい数字がaの前にあることを意味して、いくつかの数の逆順序の対の個数が数です.
3.数値aを3のノードに配置し、すべてのノードの数値を更新します.
4.最後に算出したsumは、1つのシーケンスの逆シーケンス数である.
#include <iostream>
#include <cmath>
#include <stdio.h>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <iomanip>
#include <algorithm>
#include <memory.h>
#define MAX 20000
using namespace std;

int tree[MAX];

void PushUp(int rt)
{
    tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}

void Creat(int l,int r,int rt)
{
    tree[rt]=0;
    if(l==r)
    {
        return;
    }
    int m=(l+r)>>1;
    Creat(l,m,rt<<1);
    Creat(m+1,r,rt<<1|1);
}

void Update(int p,int l,int r,int rt)
{
    if(l==r)
    {
        tree[rt]++;
        return;
    }

    int m=(l+r)>>1;
    if(p<=m)
        Update(p,l,m,rt<<1);
    else
        Update(p,m+1,r,rt<<1|1);
    PushUp(rt);
}

int Query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        return tree[rt];
    }
    int m=(l+r)>>1;
    int ans=0;
    if(L<=m)
        ans+=Query(L,R,l,m,rt<<1);
    if(R>m)
        ans+=Query(L,R,m+1,r,rt<<1|1);
    return ans;
}


int main()
{
    int n,num[5050];
    int i;
    int sum;
    int Min;
    while(~scanf("%d",&n))
    {
        sum=0;
        Creat(0,n-1,1);
        for(i=0;i<n;i++)
        {
            scanf("%d",&num[i]);//    
            sum+=Query(num[i],n-1,0,n-1,1);//   num             
            Update(num[i],0,n-1,1);//                
        }
        Min=sum;
        for(i=0;i<n;i++)//      
        {
            sum+=n-2*num[i]-1;
            Min=min(Min,sum);
        }
        if(Min<0)
            Min=0;
        cout<<Min<<endl;
    }
    return 0;
}

集計ソートテンプレートで作成したものを添付します.集計ソート自体には2つの配列が必要であり、両方の配列が変更されるので、一時的でなければなりません.
#include <iostream>
#include <cmath>
#include <stdio.h>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <iomanip>
#include <algorithm>
#include <memory.h>
#define MAX 20000
using namespace std;

int a[5050];
int c[5050];
int num[5050];
int cnt;

void MergeSort(int l,int r)
{
    int mid,i,j,tmp;

    if(r>l+1)
    {
        mid=(l+r)/2;
        MergeSort(l,mid);
        MergeSort(mid,r);
        tmp=l;
        for(i=l,j=mid;i<mid&&j<r;)
        {
            if(a[i]>a[j])
            {
                c[tmp++]=a[j++];
                cnt+=mid-i;
            }
            else
                c[tmp++]=a[i++];
        }
        if(j<r)
            for(;j<r;j++)
            c[tmp++]=a[j];
        else
            for(;i<mid;i++)
            c[tmp++]=a[i];
        for(i=l;i<r;i++)
            a[i]=c[i];
    }
}

int main()
{
    int n;
    int i;
    //int sum;
    int Min;
    while(~scanf("%d",&n))
    {
        cnt=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&num[i]);//    
            a[i]=num[i];
        }
        MergeSort(0,n);
        Min=cnt;
        for(i=0;i<n;i++)//      
        {
            cnt+=n-2*num[i]-1;
            Min=min(Min,cnt);
        }
        if(Min<0)
            Min=0;
       cout<<Min<<endl;
    }
    return 0;
}