HDU 1711:Number Sequence(KMP)
Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3411 Accepted Submission(s): 1539
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
Sample Output
サブストリングがプライマリストリングの最初に現れる位置を特定
ソース:
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3411 Accepted Submission(s): 1539
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
サブストリングがプライマリストリングの最初に現れる位置を特定
ソース:
#include<iostream>
using namespace std;
const int MAXM=10005;
const int MAXN=1000005;
int p[MAXM],n,m,a[MAXN],b[MAXM];
void PreKMP()
{
int i,j;
p[1]=0;
j=0;
for(i=2;i<=m;i++)
{
while(j>0 && b[i]!=b[j+1])
j=p[j];
if(b[i]==b[j+1]) j++;
p[i]=j;
}
}
int KMP()
{
int i,j=0;
PreKMP();
for(i=1;i<=n;i++)
{
while(j>0 && a[i]!=b[j+1])
j=p[j];
if(a[i]==b[j+1])
j++;
if(j==m)
return i-m+1;
}
return -1;
}
int main()
{
int T,i;
cin>>T;
while(T--)
{
cin>>n>>m;
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
for(i=1;i<=m;i++)
scanf("%d",&b[i]);
cout<<KMP()<<endl;
}
system("pause");
return 0;
}