HDU 3666 THE MATRIX PROBLEM差分制約システム
THE MATRIX PROBLEM
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3001 Accepted Submission(s): 784
Problem Description
You have been given a matrix C
N*M, each element E of C
N*M is positive and no more than 1000, The problem is that if there exist N numbers a1, a2, … an and M numbers b1, b2, …, bm, which satisfies that each elements in row-i multiplied with ai and each elements in column-j divided by bj, after this operation every element in this matrix is between L and U, L indicates the lowerbound and U indicates the upperbound of these elements.
Input
There are several test cases. You should process to the end of file.
Each case includes two parts, in part 1, there are four integers in one line, N,M,L,U, indicating the matrix has N rows and M columns, L is the lowerbound and U is the upperbound (1<=N、M<=400,1<=L<=U<=10000). In part 2, there are N lines, each line includes M integers, and they are the elements of the matrix.
Output
If there is a solution print "YES", else print "NO".
Sample Input
3 3 1 6
2 3 4
8 2 6
5 2 9
Sample Output
YES
Source
2010 Asia Regional Harbin
Recommend
lcy
n*mの行列Xと数L、Uを与え、n個の数ai、およびm個の数bjを求め、Xij*ai/bjがLからUの範囲内にあるようにする.
最初に不等式を見たときは差分拘束システムかもしれないと推測していましたが、不等式の中に乗算があってどうすればいいか分からず、対数を取って乗算を加算に変換すればいいことがわかりました.
次に不等式を見てみましょう.
L<=Xij*ai/bj<=U ==>
L*bj<=Xij*ai<=U*bj ==>
L*bj-Xij*ai<=0
Xij*ai-U*bj<=0 ==>
log(L*bj)-log(Xij*ai)<=0
log(Xij*ai)-log(U*bj)<=0 ==>
logbj-logai<=logXij-logL
logai-logbj<=logU-logXij
これにより,標準的な差分制約システムの不等式に変換される.
だから図を建てて、n+m個のノードがあります
iからj+nまで辺をつなぎ、辺権はlog(Xij/L)
j+nからiは辺をつなぎ,辺権はlog(U/Xij)である.
次にspfaを用いて負ループがあるか否かを判断し,負ループがあることは不等式群の無解を説明する.
しかし普通のbellmanではspfa判定負ループがタイムアウトし、再帰的なspfaもだめで、
経験式を使うしかありません.
1.cnt[]レコードノードがキューに参加した回数は,sqrt(n)より大きく,負のループと見なすことができる.
2.sumはすべてのノードが2*(n+m)より多くのキューに参加したことを記録し,負のループとした.
しかし、これは正しくありません.データを見なければなりません.
コード:
入力外挂けをつけてやっと400 msまで最适化しました...
#include<cstdio>
#include<cstring>
#include<cmath>
#define inf 999999999
using namespace std;
int n,m,num,adj[805],f[805],q[10005];
double dis[805],L,U;
struct edge
{
int v,pre;
double w;
}e[320005];
void insert(int u,int v,double w)
{
e[num].v=v;
e[num].w=w;
e[num].pre=adj[u];
adj[u]=num++;
}
int spfa(int x)
{
int i,v,sum=0,head=0,tail=0;
memset(f,0,sizeof(f));
for(i=0;i<n;i++)
dis[i]=inf;
dis[0]=0;
q[tail++]=x;
while(head<tail)
{
x=q[head++];
f[x]=0;
for(i=adj[x];~i;i=e[i].pre)
if(dis[v=e[i].v]>dis[x]+e[i].w+1e-8)
{
dis[v]=dis[x]+e[i].w;
if(!f[v])
{
sum++;
if(sum>2*(n+m))
return 0;
f[v]=1;
q[tail++]=v;
}
}
}
return 1;
}
inline int getint()
{
char c=getchar();
while(c<'0'||c>'9')c=getchar();
int n=c-'0';
c=getchar();
while(c>='0'&&c<='9')
{
n=(n<<1)+(n<<3)+c-'0';
c=getchar();
}
return n;
}
int main()
{
while(~scanf("%d",&n))
{
int i,j,k;
num=0;
memset(adj,-1,sizeof(adj));
m=getint();
L=getint();
U=getint();
for(i=0;i<n;i++)
for(j=0;j<m;j++)
{
k=getint();
insert(i,j+n,log(k/L));
insert(j+n,i,log(U/k));
}
n+=m;
m+=m;
if(spfa(0))
puts("YES");
else
puts("NO");
}
}