hdu1003 Max_Sum


Max Sum
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 130593    Accepted Submission(s): 30266
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input

  
   
   
   
   
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

 
Sample Output

  
   
   
   
   
Case 1: 14 1 4 Case 2: 7 1 6

 
Author
Ignatius.L
 
#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int t, j, m, n, s, e;
    int start,end, max;
    int cur;
    int sum;
    //freopen("test", "r", stdin);
    cin >> t;
    for(m = 1; m <= t; m++)
    {
        cin >> n;
        cin >> cur;

        sum = max = cur;
        s = e = start = end = 0;

        for(j = 1; j < n; j ++)
        {
            cin >> cur;
            if(cur > cur + sum)//sum     
            {
                start = j;
                sum = cur;
                end = j;
            }
            else
            {
                sum += cur;
                end = j;
            }

            if(sum > max)//      max
            {
                s = start;
                e = end;
                max = sum;
            }
        }

        cout<<"Case "<<m<<":" << endl << max <<" " << s+1 << " " << e+1 << endl;
        if(m != t)
            cout << endl;
    }
    return 0;
}