JAVA練習——数字をカンマで区切る
759 ワード
C言語実験——三つの整数の最大値を求める
Time Limit: 1000 ms
Memory Limit: 65536 KiB
Submit Statistic
Problem Description
プログラムを作成して、3つの整数を入力して、その中の最大値の出力を求めてください.
Input
1行に3つの整数を入力し、整数間をカンマで区切ります.
Output
3つの数の最大値を出力します.
Sample Input
Sample Output
max=9
Time Limit: 1000 ms
Memory Limit: 65536 KiB
Submit Statistic
Problem Description
プログラムを作成して、3つの整数を入力して、その中の最大値の出力を求めてください.
Input
1行に3つの整数を入力し、整数間をカンマで区切ります.
Output
3つの数の最大値を出力します.
Sample Input
5,7,9
Sample Output
max=9
import java.util.Scanner;
public class Main{
public static void main(String args[]) {
Scanner cin = new Scanner(System.in);
String s1 = cin.nextLine();
String[] s2 = s1.split(",");// s1 , s2
int a = Integer.parseInt(s2[0]);//
int b = Integer.parseInt(s2[1]);
int c = Integer.parseInt(s2[2]);
int max = a;
if(max